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A note from the author: 

Hello! Thank you for checking out this course. I designed this PDF to be 
an additional resource for you to reference with the videos. The video 
gives the full process including some context for each of the different 
tools and techniques. In this PDF you will find notes which outline the 
steps required to complete each video. Think of this as at the key 
summary overview for each video in the course. If you find yourself ever 
wondering about what you saw in the videos please give this PDF a 
look for your reference. Once again, thank you so much for taking the 
time to explore this course.  
 
Sincerely: Ian Robinson - ian@softboxmedia.com 



1. Create and Animate Text Using Presets

Text presets are like the ultimate cheat code when animating type in After 
Effects. In this tutorial we go over how to apply and adjust text presets so 
you can create something engaging both quickly and with precision. 

When you select a text layer in the timeline, you can pick a font and format 
the type using the Properties panel. 



Create an Animate Text Using Presets

1. Bring the Effects and Presets panel to the front

2. Select the Text Layer and Position the Current 

Time Indicator on the frame where you’d like 
the animation to start


3. Drag and drop the preset onto the text layer 
either in the Timeline or Composition Panel, 
(you can also simply double click on the preset 
to apply it to the selected text layer 


4. Press the Spacebar to preview the animation

1. After applying the preset, open the text properties, and the preset properties to 
reveal the Advanced section


2. Use the Based On dropdown menu to change the animation from Characters to 
Words (so now the preset will animate word by word instead of letter by letter)



Create an Animate Text Using Presets

1. Move the Current Time Indicator down the timeline to where you want the 
animation to start, then double click the Preset you’d like to apply. (In the 
tutorial we went to the Animate Out folder in the presets and applied the 
Decode Out by Random Character preset).


2. Press the spacebar to preview the animation 


Make the text flicker more by applying another preset.  

3. Move the Current Time Indicator Down the timeline to just before the other 
preset you just applied and apply the Opacity Flicker Out preset 

4. Press the space bar to preview the animation

To create the text animating out of the scene, simply repeat the same 
process as above. 



2. Dynamic Titles

In this tutorial, we are going to create an animated title, using Text layers 
and Shape layers. Then we are going to create both a lower third and a 
generic infographic utilizing the same techniques, and reusing as many of 
the elements as possible… across each of the different graphics

Duplicate the Cold Plunge comp 2 times to 
get three compositions total. Then rename 
them to match the image below. 



1. Open the Cold_Plunge-Title Comp

2. Grab the Horizontal Type Tool from the tools panel 

3. Type “Cold Plunge” with each word on it’s own line in the center 

of the Composition panel

4. Resize the word Cold to match the width of the word Plunge 

using the text options in the Properties panel 

Dynamic Titles

1. Select the Rectangle shape tool and draw a vertical rectangle 
over the type layer


2. Set the Fill to a Gradient Fill, and the stroke to white 

3. Adjust the settings of the gradient and stroke to match the image 

grab below



Dynamic Titles

1. Change the order of the layer stack so the Shape layer is below 
the type layer


2. Drag the snowflake Illustrator file from the project panel into the 
newly created shape layer to match the image below

1. Select the top 3 layers (snowflake.ai, cold plunge, Shape Layer 1)

2. Trim the layers to start at 4 seconds

3. Select the Snowflake.ai layer and go to Layer > Create > Create 

shapes from Vector Layers



Dynamic Titles

1. On the Snowflake Outline layer go to Add > Repeater 

2. Open the settings for the Repeater 1 position and set them to 

0.0,-233

3. Keyframe the Offset and Copies properties for Repeater one so 

the snowflake falls into the scene over one second… (starting at 4 
seconds in the timeline)

Much like Text Layers have Text Animators, Shape Layers have animators 
under the Add button, which create a whole other level of animation 
possibilities. In this tutorial we will animate with a Repeater to make the 
snowflake look like it’s falling as it animates into the scene 

Now it’s time to take what you learned from animating the snowflake shape 
layer and apply it to animating the CP Rectangle layer by adding a Trim 
Paths function to the layer, and keyframing the appearance of the stroke. 

1. Animate the Trip Path End property from 0 to 100% at 5 seconds

2. Animate the Gradient Fill Opacity once the stroke animates into 

the scene 



Dynamic Titles

1. Move the Current Time Indicator to at 0:00:06:13 and trim the 
start of the text layer to match


2. Apply the Slow Fade On text animation preset 

3. Press Spacebar to preview the animation 

Since the animation finishes around six seconds, let's move the text layer to 
start after and apply a text preset using the techniques we learned in the 
previous video

When building new animated graphics from other animated compositions 
you must remember it is always easier to delete then create from scratch. 
We are going to start building our lower third by copying any layers we 
might need from the title animation.

Building the Lower 3rd with elements from the Title animation 

1. Copy the top 4 Layers from the Cold_Plunge-Title Composition

2. Paste those layers into the Cold_Plunge-3rd Composition

3. Slide all the layers to start at the beginning of the composition as 

one group, (so the text layer still starts around 2 seconds

4. Remove any unwanted animation by deleting keyframes or layers

5. Delete the Snowflake shape layer and turn on the visibility of the 

Snowflake Illustrator layer

6. Enable Title and Action safe at the bottom of the Comp Panel

1. Select the CP Rectangle layer and press UU quickly on the 
keyboard to reveal any property that has changed from it’s default 
state, (and any animated properties). 



2. Change the size of the rectangle to span the composition panel 
almost the size of the outer-most safe line displayed by the Title 
and Action safe button.

Dynamic Titles

3. Reposition and resize the layers over to the lower 3rd area at the 
bottom of the screen, roughly match the image below.



4. Select the CP Rectangle Layer and press U to reveal any 
animated properties


5. Slide those keyframes to start near the beginning of the 
composition


6. Trim and animate the Opacity of the Snowflake.ai layer to start 
just after the stroke of the box animates in


(roughly match image below) 
7. Press the spacebar to preview the animation 

Dynamic Titles

Now we have successfully animated the lower third using elements from 
the animated title. Now we can take these elements and create one last 
graphic, the generic full page infographic (which we can always customize later)

Building the full page info-graphic with elements from the 
Lower 3rd animation 

1. Copy the top 3 layers from the Cold_Plunge-3rd comp 

2. Paste those layers into the Cold_Plunge-Info comp

3. Make sure your layers are stacked properly so you can see 

everything (see below)

4. Turn off the visibility of the Corner_Logo layer 

5. With the CP Rectangle layer selected, quickly press UU to reveal 
any animated properties


6. Resize the Rectangle Path size on that layer to the rough size of 
Title and Action safe 



Dynamic Titles

6. Reposition all the layers to match the image below

6. Select the Horizontal Type Tool and add another text layer to 
match the image below


7. Apply the “Straight In Multi-Line” Text animation preset to have 
the type animate into the composition line by line

6. Select the Ice_Plunge 
video layer at the bottom 
of the timeline


7. Right-Click or 
Control+Click and 
choose > Guide Layer

Guide Layers allow you to see the 
layer in your comp, but in edit or 
render, it will be transparent.



3. Working More Efficiently Between After Effects and 
Premiere Pro

Dynamic link,  allows you to easily go back-and-forth between Premier Pro, 
and After Effects without having to render between applications. It 
continually sends creative changes back-and-forth between both 
applications. In this project, we are going to feature some of the most 
common reasons one might want to send a video back and forth between 
applications.  
For the first part, we will be sending a video from Premiere Pro to After 
Effects so we can take advantage of the excellent tracking, masking, and 
generative fill tools available.  
For the second part, we will be importing an After Effects composition into 
Premiere Pro so we can quickly create multiple versions of our graphic 
without having to render anything out of After Effects. 

1. In your Ae_10 folder, open the 
03_Dynamic_Link folder


2. Open the 03_PrPro_Projects 
folder and open the 
Dryp_Edit.prproj file 

Take note of the folder structure. Whenever starting a new project, this is 
the general folder structure I use for everything in that project. Keeping files 
organized is most important when working with Dynamic Link.

3. In Premiere Pro, open the 
Dryp_Training sequence 

Since we want to add graphics into 
our video footage, we need to use 
tools like the 3D Camera Tracker in 
After Effects to achieve that effect. 



3. In Premiere Pro, open the 
Dryp_Training sequence 


4. Right-Click or Control+Click on 
the second clip in the timeline 
and choose > Replace with After 
Effects Composition 


5. Save the project in the 
Ae_Projects folder and call it 
Track_Track_PrPro.aep

Since we will be covering how to use the 3D Camera Tracker in another 
lesson, we are going to just copy and paste the layers into the project so 
we can stay focused on the goal of this lesson… Dynamic Link. 

1. Import the Placed_Text after 
effects Project 


2. Copy the layers as shown in the 
image on the right  


3. Paste those layers into the 
Dryp_Edit Linked Comp

1. Scrub through the comp to see 
how the text moves through the 
scene


2. Go back to Premiere Pro to see 
how this now appears right in 
the timeline


3. Go back to After Effects and 
change any type layer


4. Go back to Premiere Pro to see 
the results 

Notice how we did not have to save any 
project, the creative changes continually 
update between applications.

Dynamic Link



Now that we’ve seen how to send files from Premiere Pro to After Effects, 
let’s look at how to link After Effects compositions directly into Premiere Pro.

1. In your Ae_10 folder, open the 
03_Dynamic_Link folder


2. Open the 02_Ae_Projects folder and 
open the Lower_3rd.aep project file


3. Open the Lower_3rd composition 
(found in the project panel)

The lower 3rd graphic was designed as a general template. Looking at the 
bar, I can see it’s too large for what we need in this instance. 

Dynamic Link

1. Resize the bar by selecting the CP Rectangle layer and pressing UU to 
reveal any animated properties


2. Change the size of Rectangle Path 1 on the X property down so the bar 
is just a little bit larger than the text 


3. Change the position of the Transform: Rectangle 1 property so the bar 
is back under the text 


4. Right-click or Control+Click on the video layer Ice_Plunge.mp4 and go 
up to Guide Layer (this will make the layer transparent when the composition is added 
onto a video track in Premiere Pro)

We are now ready to import the Lower_3rd composition into Premiere Pro

1. Go back to Premiere Pro and double click in the Project panel to open 
the Import dialogue 


2. Navigate to the Lower_3rd.aep file and double click to import

3. When prompted, choose the Lower_3rd comp and click OK

4. Drag the Lower_3rd comp into the timeline and place it on video track 2 

right above the other video clips. (Make sure the Lower 3rd starts right at frame 0) 
5. Trim the end of Lower 3rd video clip so that it ends at the same time as 

the first shot in the sequence



At this point, the lower 3rd text could be changed in Premiere Pro without 
going back to After Effects. But if we scrub the sequence in Premiere Pro, 
we’ll see how the animation isn’t even finished animating in before the clip 
ends. A timing change like this requires us to go back to After Effects to 
make changes. We can do that by right clicking on the Lower 3rd clip directly 
in the Timeline and choosing Edit Original, or if the project is already open in 
After Effects, we can just go back into After Effects and make any changes. 

1. In the Lower 3rd comp in After Effects, select the text layer at the top of 
the layer stack in the timeline and press U to reveal any animated 
properties 


2. Select the right keyframe in the timeline and drag it to just around 2 
seconds in the timeline to speed up the text animation 


3. Go back to Premiere Pro to check out the animation 

Dynamic Link

If we wanted to use this graphic the way it currently stands, we would be 
finished at this point. However, the power of working with After Effects 
compositions in After Effects is the ability to change the type directly in 
Premiere Pro without having to go back to After Effects. Let’s explore how to 
change the type in Premiere Pro.

1. In Premiere Pro, double-click on the Lower 3rd comp clip in the timeline 

2. In the Effect Controls in the Source tab, change the word “plunge” to 

“power” 

Notice how the size of the type changed to match the size of the upper 
word? In After Effects, you can select individual words or letters and change 
their sizes, (and have more than one size within one type layer). Premiere Pro 
really prefers to only have one size per one text layer. To fix this, we need to 
go back to After Effects and split the text layer into two separate layers. 

1. Back in After Effects, in the Lower 3rd comp, duplicate the cold plunge 
text layer (select the layer and press Command + D or Control + D) 

2. Change the top type layer to “COLD” (font size 206) 
3. Change the second type layer to “PLUNGE” (font size 150) 
4. Go back to Premiere Pro and delete the comp from the timeline, and 

delete the linked comp from the Project panel  
5. Import the Lower_3rd After Effects comp back into Premiere Pro 
6. Add the newly imported composition back into the timeline on video 

track 2 and trim the end to match the duration of the first clip 
7. Play back the sequence to view the animation 



Since both lines of type now animate on at the same time, we need to jump 
back into After Effects to make one last change. 

1. In After Effects, slide the type layer “cold” to start at 1 second in the 
timeline  

2. Go back to Premiere Pro and watch the sequence

Now that we have worked out the workflow for having two different font sizes 
in one graphic, we are ready to customize our graphic. Since the 
composition has been imported we can duplicate the comp for each version 
of the graphic needed. Let’s create 2 different versions in the sequence. 

1. Double-click on the Lower 3rd comp clip in the timeline 

2. In the Effect Controls in the Source tab, change the word “plunge” to 

“power” 

3. Hold down Option or Alt and drag the lower 3rd over the 3rd clip in the 

timeline to create another copy, (notice the duplicate of the comp in the 
Project panel as well as in the Timeline)


4. Double-click on the newly created Lower 3rd comp clip in the timeline 

5. In the Effect Controls in the Source tab, change the word “power” to 

“energy” 

Dynamic Link



4. Graphics in Video 

In this tutorial we dive into a very popular visual effects technique where 
text is inserted into video, matching the movement of the elements in the 
scene. In this specific instance we will make the type appear as though it’s 
sitting on the track to the side of our runner. 

1. In your Ae_10 folder, open the 
04_Graphics_into_Video folder


2. Open the 04_GFX_in_Video.aep 
file


3. Open the Ref_Finished_Comps 
folder and open the 
Placed_Text_Reference 
composition


4. Scrub through to preview what 
we will be creating 

1. Open the Place_Text 
composition and select the 
video layer in the Timeline


2. Go to Animation > Track 
Camera


3. Move the Current Time Indicator 
to 0:00:02:14 in the timeline


4. Select the 3 track points on the 
track 


5. Resize the target in the Effect 
Controls panel if needed 

Tip: You can reposition the target in the 
scene by hovering over the middle of the 
target until the move tool appears.You can 
resize the track point size and the target 
size in the Effect Controls panel. 



Graphics in Video

1. Hover over the middle of the target, Right-click, and choose Set Ground 
Plane and Origin


2. Hover over the middle of the target, Right-click, and choose Create Solid 
and Camera


3. Select Track Solid 1, check the position, and make sure it’s at 0,0,0

4. Select the Horizontal Type tool from the Tools panel, click in the 

Composition panel and add the word “DEDICATION” in all caps 

5. Enable 3D on the text layer in the Timeline

6. Change the Position data to 0,0,0

7. Use the Axis handles of the 3D Gizmo to reposition the type in the scene 

Normally this would be a great place to stop. In this tutorial I’m sharing 
some of my favorite techniques to troubleshoot when the track is too 
perfect. In this instance as you scrub through the timeline you’ll notice the 
type appears to jiggle in the scene a little bit. Let’s check out how to fix this. 

1. Select the Camera layer in the timeline and press U to reveal the keyframes 

2. Scrub through the timeline to see where the word starts to shake in the 

scene

3. Delete the Position keyframes over that section, (I deleted from about frame 

13 through about 2:15 in the timeline)

This technique worked well because there were still plenty of keyframes left 
to keep the same general camera movement. Also, since the type just 
needs to stay on the track, it’s okay if it moves a little bit from its original 
placement on the track. 

In order to add more realism and polish to the scene, let’s make the type go 
in and out of focus as the camera moves past. We can do that by enabling 
and adjusting some of the Camera Options. 

1. Select the Camera layer in the timeline

2. Go to the Properties panel on the right and enable Depth of Field in the 

Camera Options section

3. Shorten the Focus Distance setting to 450 

4. Scrub the timeline or press the Spacebar to preview the animation 



5. Get faster in 3D space with Cameras, Lights, 
and Material Options

This tutorial is divided into two sections. Section one, we cover the different 
kinds of Cameras available in After Effects. Section two, we add lights and 
shadows to our text placement animation as we get more familiar with how 
to work in 2D layers in 3D space. 

1. In your Ae_10 folder, open the 
05_2D_Layers_in_3D_Space folder


2. Open the 
05_2D_Layers_in_3D_Space.aep 
file


3. Create a new comp and match the 
comp settings here


4. Select the Horizontal Type Tool and 
type the number 1 into the scene 


5. Position the number in the center 
of the composition panel 

6. Enable 3D on that layer



Get faster in 3D space with Cameras, Lights, and Material Options

7. Go to Layer > New > Camera  
to add a new camera to the 
composition


8. Choose Two Node Camera 
from the drop-down in the 
Type area of the Camera 
Options panel (then match the 
rest of the settings from the 
image then click OK)

9. Expand the Composition panel to reveal all the options in the bottom 
of the panel 

A. Draft 3D will disable things like shadows to speed up rendering in 
the comp panel when trying to work with a complex 3D scene. We 
didn’t need it for this example since it was rather simple.

B. The Renderer drop-down will change how the comp is rendered. 
When working with 2D in 3D space, Classic 3D is the one to use. If 
we were using 3D Models, then the Advanced 3D Renderer would 
be the best. 

C. Choose a view to view the scene from. Custom View 1 is like viewing 
a stage from one side while being up in the rafters. It’s like having a 
birds eye view of the scene 

D. Choose the number of viewports you want to open to be able to 
view the scene from multiple angles

A B C D

E

E. The Point of Interest, (A One-Node Camera does not have a Point of Interest). A 
2-Node Camera will always point at its Point of Interest. 



Get faster in 3D space with Cameras, Lights, and Material Options

Use 2 Views or 4 Views to view the scene from more than one angle. In this 
example, we are using 2 Views to see the scene from Custom View 1 on the 
right, and to see what the camera is looking at on the Left (Active Camera 
view) 

A Two-Node Camera has a point of interest setting, and this setting makes 
it very simple to control exactly what the camera is looking at. A One-Node 
Camera’s view will change as the camera is moved. When moving it around, 
I like to think it functions just like how a camera would move if I were 
holding it in my hands. 

Now that we have gone through how to better view a scene, and some of 
the differences between One-Node and Two-Node Cameras, we are ready 
to start working with Lights, Shadows, and Material Options. 

1. In your Ae_10 folder, open the 05_2D_Layers_in_3D_Space folder

2. Open the 05_2D_Layers_in_3D_Space.aep file

3. Open the 2D Layers in 3D Space composition 

4. Go to Layer > New > Light - And choose Point Light 

I chose Point Light because it throws light in all directions, and can cast 
shadows.  



1. Match the Light Settings from the image 
on the right, and press OK


2. Reposition the light in the scene by 
holding down shift and pointing the Pick 
Whip from the light layer to the Text layer

Get faster in 3D space with Cameras, Lights, and Material Options

1. Match the lights settings and press OK

2. Reposition the light in the scene by 

holding down shift and pointing the Pick 
Whip from the light layer to the Text layer


3. Reposition the light slightly up and 
behind the text layer in the composition 
panel 


4. Change the Material Options for the 
Dedication layer to match below



5. Turn on the visibility for the Track Solid 
Layer and reveal it’s material options


6. Change Accepts Shadows setting to only

7. Feel free to adjust to your liking, move 

the light or Track Solid Layer around 

Get faster in 3D space with Cameras, Lights, and Material Options

Now that we have one setup done for the track, we just need to add two 
additional words to the track. We can do this by using parenting, and 
duplicating the Solid, Text, and Light layers.  

8. Using the Pick-whips, make the Point light follow the Dedication layer 

9. Make the Track Solid follow the Dedication layer 

10. Feel free to adjust to your liking, move the light or Track Solid Layer around 

1. Duplicate the top 3 layers

2. Move the duplicated layers to the stop 

of the layer stack in the timeline panel

3. Use the 3D Gizmo to reposition the 

newly duplicated layers 

4. Keep aware of the axis mode as you 

move layers around

5. Change the text of layer 2 to read 

“SWEAT”



Get faster in 3D space with Cameras, Lights, and Material Options

To finish the project, repeat the steps for duplicating and repositioning the 
new copies. Change the last text layer to read “HEART” 



6. Masking Techniques, Blend Modes, and Track Mattes
This tutorial covers some of the most common reasons for using masks, 
track mattes and blend modes. First we will use masks and the rigid mask 
tracker to remove some distracting elements from a scene. Then we will 
use track mattes and blend modes to create a composite with graphics 
overtop of the scene. 

1. In your Ae_10 folder, open the 
06_Masking_BlendModes_TrackM
attes folder


2. Open the 
06_Mask_Blend_Track.aep file


3. Open the comp in the 
01_Finished_Ref_Comps if you 
want to check out what we will be 
creating 

1. Open the Mask_Matte_Blend Modes comp 

2. Select the Treadmill.mov layer in the timeline

3. Select the Rectangle Tool from the Tools panel 

4. Draw three rectangles around the three distracting signs in the footage

5. Change their modes to None in timeline

TIP: as long as you have a layer selected in the Timeline panel, your cursor will have the Mask 
icon on the lower right of the cursor. If you see a star next to your cursor, you don’t have a 
layer selected in the timeline and you will create a Shape Layer instead of a Mask on a layer. 



Masking Techniques, Blend Modes, and Track Mattes

1. Select all the masks in the Timeline, right-
click and choose Track Mask


2. In the Tracker panel choose Position, 
Scale & Rotation


3. Use the Analyze buttons to activate the 
tracker, (stop the tracker and make adjustments to 
the masks if they appear to be going off course)

Now that we have the masks tracked over the signs and elements we’d like 
to remove, we can utilize Content-Aware Fill for video to fill in the areas 
where the signs were. In order to do that, we must first make sure the area 
inside the masks are transparent. Let’s get to it! 

1. Set all the Mask mode for all 3 Masks to Subtract

2. Go to Window > Content-Aware Fill to open the panel 

3. Set the panel to match the still on the right, and

press Generate Fill Layer



To recap, we used masks and the Rigid Mask Tracker to select objects in 
the scene we would like to remove. We have also removed those elements 
utilizing Content-Aware Fill for video. Now we can start adding graphics to 
the project, and using a track matte and blend modes to blend those 
graphics into the scene. We’ll start by adding our logo into the corner. 

Masking Techniques, Blend Modes, and Track Mattes

1. Drag the DRYP - Tag.mov file from the Graphics folder in the Project 
panel into the timeline, (this graphic has no alpha channel so we need to use a track 
matte to create transparency from the black and white pixels)


2. Go to Layer > New Solid and add a white solid the size of the comp to 
the composition


3. Position the solid under the logo layer and use the Travel Matte Pick 
Whip to have the layer solid use the logo layer as the matte 

4. Change the matte type from Alpha matte to Luma Matte by clicking the 
icon on the right side of the track matte drop down


5. Reposition the Dryp - Tag.mov layer into the lower right corner of the 
composition panel, and adjust the scale down for a better fit

To recap, we just used a Track 
Matte to use the brightness of the 
pixels on one layer determine the 
transparency of another layer. 



1. Drag the dryp_purple_spin.mov file from the Graphics folder in the 
Project panel into the composition panel, and position it on the left side 


2. Change the Blend Mode for the layer to Add

3. Add a Glow effect onto the can to make it look a little more dreamy, 

(adjust the glow radius to magnify the look)

4. In the Effects & Presets panel search for “flicker” and apply the VHS 

Flicker Effect onto the dryp_purple_spin layer in the comp

5. Duplicate the dryp_purple_Spin layer in the timeline and scale up the 

duplicate to something around 800%

6. Change the transparency of the large layer down to something near 30%

For the last bit of this tutorial, we are going to add some Dryp sports 
drink graphics over the scene. We will use Blend Modes to mix the 
layers together to create one dynamic cohesive look. 

Masking Techniques, Blend Modes, and Track Mattes

As you can see in the composite; masks, mattes, and blend modes 
are a great way to tie all your layers together and create one cohesive 
look for your motion graphics. 



7. Rotoscoping

This tutorial covers how to remove a person from their background utilizing 
a tool custom made for rotoscoping in After Effects called the Roto Brush 
tool. Even with video that might not have a very strong contrast between 
the foreground and background, the Roto Brush Tool does a remarkable job 
and saves a ton a time. 

1. In your Ae_10 folder, open the 
07_Roto Brush.aep file


2. In the 00_Comps folder, open the 
07_Roto Brush comp 


3. Double-click on layer one to load it 
into the Layers panel


4. Choose the Roto Brush tool from 
the tools panel 


5. Click and drag inside the athlete to 
begin the process of selecting her 



Rotoscoping

1. Hold down Option (or Alt) and 
begin to drag outside the area 
selected, and drag over into the 
area you’d like to deselect 


2. You can also start inside the 
selection, and drag out to select 
more area


3. Once you have a selection you like, 
press the spacebar to have the 
selection continue isolating our 
athlete from the background over 
the rest of the video clip 

Once the selection goes over 
all the frames in the timeline, 
you’ll see that timeline turn 
green in the bottom of the 
layer panel 

1. Grab the Refine Edge Tool

2. Move the Current Time Indicator 

back to the beginning of the 
timeline and slowly trace over the 
edges along her hair to create a 
more precise edge along that hair

When you’re finished, the selection 
will look something like this

3. Press the spacebar to propagate 
the refine edge down the rest of 
the timeline



4. As the frames continue to load down the timeline, you can stop playback 
at any time and add additional refine edge strokes if you so choose


5. Once you are satisfied with how the selection is looking, press the Freeze 
button in the lower right corner of the Layer panel, (this will freeze the selections 
so as one plays the clip back, the Roto Brush won’t re-analyze the frames again and make 
new selections)

Rotoscoping

6. Copy the Deep Purple Solid 1 layer and the dryp_purple_Spin.mov layer 
from the 07_Roto Brush_Ref comp and paste them in the 07_Roto Brush 
composition below the newly rotoscoped layer 


7. Drag a copy of the Smile.mov layer from the Project panel to the bottom 
of the layer stack. 


8. Apply a Fast Box Blur to that lowest layer in the stack and crank up the 
Blur Radius to something around 24



8. Working with 3D Models

This tutorial goes over the key settings and options to know about when 
adding 3D models directly to your After Effects Composition. The most 
important thing to remember is the fact that none of this would be possible 
without utilizing the Advanced 3D Renderer

1. In your Ae_10 folder, open the 
08_3D_Models.aep file


2. In the 00_Comps folder, open the 
3D Models comp 


3. Drag the Sportswatch_Closed.glb 
file into the timeline 


4. Adjust the model settings dialogue 
box to match the image below and 
click OK 

5. Open the Scale settings for the 
watch layer and change it to 50%


6. Use the 3D Gizmo to rotate the 
watch into position 


7. Adjust the Scale setting as needed

If you ever decide you need to access the Model Settings dialogue box 
again, go to Layer > Model Settings to open them up. 



5. In the Renderer drop-down menu in the lower right corner of the 
composition panel, choose Renderer Options


6. Set the options to match the image below and press the Fit to Scene button 
to get the shadows to better match the model

To make the model pop off the background we are going to add an 
Environment Light and a shadow catcher layer.

7. To add an Environment Light to the scene go 
to Layer > New > Light 


8. Choose the Environment Light from the Light 
Type drop down and adjust the settings to 
match the image to the right and press OK 

You may notice that things haven’t changed 
much. That’s due to the fact that an 
Environment Light needs a source layer to 
create the light from. 

9. Open the HDRI folder in the Project panel 
and drag the Studio_Small_08_4k.hdr into  
the layer stack in the Timeline


10. In the Light Options for the Environment 
Light Choose the Studio_Small_8_4k.hdr 
from the drop down 


11. Toggle the Environment light layer on and off 
to see the difference in lighting on the mode.

Working with 3D Models 



Since we have an Environment Light that casts shadows in our 
composition, we should add a shadow catcher layer 

Working with 3D Models 

1. Go to Layer > New > Solid and make the solid whatever color you like and 
make sure it’s a comp sized layer


2. Slide the layer back on the z so that it is behind the watch layer

3. Open the Layer Material Options and change the setting for Accept 

Shadows to Only

4. Play with the Rotation settings for the Environment Light to change how 

the lighting appears

5. Adjust the intensity light settings to adjust the brightness of the light 

settings 

Layers made from 3D models cannot have effects applied to them, but 
there is a way around that by using the Calculations effect.

1. Go to Layer > New > Solid and make the solid white, and make it the size 
of the composition and move it to the top of the layer stack in the 
Timeline 


2. Apply the Calculations effect and change the settings to match this image

As you can see, the watch appears 
over the white solid instead of over 
everything else in the comp. To get 
the transparency back we need to 
apply another calculations effect on 
the same layer



1. Select the calculations effect in the effect 
controls and and press Command+D or 
Control+D to duplicate the effect


2. Change the settings to match this image

Working with 3D Models 

Now that we have the transparency 
back, we are all set to apply any 
effect to the layer and keep on 
working.  

Just remember, if you want to 
change the position of the model, 
you have to adjust it on the model 
layer, not on the layer solid with the 
Calculations. The calculations layer is 
referencing the 3D layer. 



9. Interactive Animations

You might be wondering what an interactive animation is. They are simply 
animations where one layer causes another layer to move, or “interact” with 
another layer in some way. In this tutorial we are going to increase our 
efficiency working in After Effects by utilizing some of the more advanced 
features used to create interactive animations. 

1. In your Ae_10 folder, open the 
09_Efficient_Layers.aep file


2. In the 00_Comps folder, open the 
3D Models comp 


3. Go to Layer > New > Null Object

4. Rename the Null “Rotation 

Control” and enable 3D on the 
layer


5. Position the Null on the left side of 
the composition panel 


6. Use the Pick Whip for the Soccer 
Ball layer and point it to the 
Rotation Control Null layer in the 
Timeline

1. Add a keyframe for the Z Rotation at about 12 frames in the timeline

2. Move the Current Time Indicator to 1 second in the timeline and rotate 

the Z setting to 90

3. Turn on the visibility for the Sports watch and make it the child of the 

Rotation Control Null 

4. Add a keyframe for the Z rotation of the Rotation Control Null

5. Move the Current Time Indicator down another 12 frames in the 

timeline

6. Rotate the Control Null another 90 degrees

7. Repeat this process of the sports bag 

8. Scrub the timeline and add any additional keyframes you might want 

to make this animation as smooth as possible 



Now that we have done some of the fundamentals like using parenting to 
control the rotation or position of another layer, now we will take things a 
step further and use the rotation of one layer determine the color of another 
layer. 

Interactive Animations

1. Select the bottom layer in the layer stack 

2. Open the effects for that layer in the bottom of the Timeline

3. Open the settings for the Color Balance (HLS) effect so we can see 

the Hue setting

4. Use the Pick Whip for the Hue setting and point it at the Rotation 

setting of the Rotation Control Null

5. Press the Spacebar to preview the animation (Enable Draft 3D so speed up 

the preview) 



10. Working with Motion Graphics Templates

In this tutorial we will export a Motion Graphic template out of After Effects 
for use in Premiere Pro as a template.Using a Motion Graphics template 
enables editing in Premiere Pro faster because you do not have to go back 
to After Effects to make a simple change in a graphic. 

1. In your Ae_10 folder, open the 
10_Editable_GFX_for_PrPro.aep 
file


2. In the 00_Comps folder, open the 
Lower_3rd composition  


3. Scrub through the project to 
preview the animation


4. Go to Window > Workspace > 
Essential Graphics to change to 
that workspace


5. In the Essential Graphics panel 
change the name to 
Schedule_Temp


6. Choose the Lower_3rd comp from 
the Primary drop down


7. Adjust the timing or settings of any 
of the animations or layers before 
beginning the process of creating 
the template


8. Use the Solo Supported Properties 
button to reveal anything that can 
be customized in in the Essential 
Graphics panel 


9. Drag the Source Text property for 
the Day text layer up into the 
Essential graphics panel 


10. Do the same for the Source Text 
property for the Activity text as well



1. In the lower left corner of the Effect 
Controls panel, go to Add 
Formatting and choose Add Group


2. Name the new group “Text” and 
drop the two text properties in it


3. Make another group and name it, 
“Bar Length”


4. Select the Medium Bar Shape layer 
and go to Layer > Pre-Compose 


5. Name the new Precomp “Medium 
Bar” 


6. Do the same thing with the Big Bar 
layer, making sure the bar is visible 
before putting it into the 
precomposition. 


7. Apply the Checkbox Control effect 
to both the Medium Bar


8. Rename the control in the Effect 
Controls panel to “Medium Bar” 


9. Do the same thing with the Big Bar 
layer, and rename that Checkbox 
Control “Big Bar” 


10. Open the Opacity for the Big Bar 
precomp


11. Link the Opacity for Big Bar to the 
Checkbox control in the Effect 
Controls panel 


12. Open the Expression and add *100 
at the end and click outside the 
box to set it 

Working with Motion Graphics Templates 

13. Open the effect in the timeline and 
drag the Checkbox property up 
into the Effect Controls panel 



14. Make a group in the Essential 
Graphics panel for the bars and 
call it Bar Length 

15. Repeat the same steps for control 
of the Medium Bar, and add that 
into the Effect Controls panel

Working with Motion Graphics Templates 



16. In order to change the color of text, we need to select the text layer and 
add an animator Animate > Fill Color > RGB


17. Drag that Fill color up to the Essential Graphics panel so it can also be 
customized in Premiere Pro

Working with Motion Graphics Templates 

16. Selecting the bottom video layer and right-click, choose > Guide Layer 
to make sure this layer shows up as transparent when the template is 
created 


17. Press the “Export Motion Graphics Template…” button and save it 
where you can find it easily



1. In Premiere Pro go to Window > Workspace > Captions and Graphics

2.  Press on the Install Motion Graphics Template button in the lower left 

corner of the Essential Graphics panel 

3. Navigate to where you saved the file and import it 

4. Drag the template into the timeline in Premiere Pro and Double click it 

to open in the Graphics section of the Text panel and customize 

5. You can also customize the graphics in the Essential Graphics panel on 

the right side of the interface 

Working with Motion Graphics Templates 



A farewell note from the author: 

Hello! And once again thank you for checking out this course! If you 
have any questions, feel free to reach out. Thanks again for your time. 
 
Sincerely: Ian Robinson - ian@softboxmedia.com 
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