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This Guide:

Your Instructor:

The videos accompanying this PDF guide are meant to welcome you to Adobe After Effects, whether 
you’re brand new to this amazing app, or if you just need to refresh your fundamentals. This guide 
reinforces the material in those videos, and also provides a broader context for other controls and 
functions. You’ll find important terms, crucial concepts and useful keyboard shortcuts. After Effects 
is a big program, so this is not designed to be a comprehensive guide, but should be a great start! 

These lessons and examples are geared towards users with at least a little bit of experience in visual 
design software and concepts, but will still be as useful even if that’s not you! After Effects is a big 
program with several additional features we won’t have time to explore in this series. 

For additional learning and resources, check out the official After Effects user guide.

I’ve been using After Effects almost every day for 20+ years, and I hope these lessons get you started 
on your own path to making awesome, fun, creative stuff that moves! 

Note: Project Files
The project files included with this download will allow you to follow along with my lessons and 
examples. You may place this entire folder anywhere you like on your system, but do not separate the 
individual files within the folders - After Effects won’t know where to look for those files!

These files have been created for After Effects 2024 (v 24.5) and may not be usable in earlier versions.

Hi, I’m Kyle! 

I’m a long-time creator with too many titles: motion designer, 
video editor, creative and technical director, Emmy winner, 
Adobe-Certified instructor, and all-around After Effects & 
Premiere Pro nerd who loves sharing knowledge. 

If you create something using the skills from these lessons, 
please feel free to tag me. I love seeing what students feel 
inspired to create! 

Find me online:
KyleHamrick.com
Social Media

A huge thanks to Jessey Libby, who created the awesome 
designs used in the lessons (and is at least partially to blame 
for the puns), and to Amanda Wilson, whose editing expertise 
helped transform my rambling into these useful videos!

https://helpx.adobe.com/after-effects/user-guide.html
http://kylehamrick.com
https://linktr.ee/kylehamrick
https://linktr.ee/jesseylibby
http://amandamademedia.com
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Creating Video: Key Concepts
While you can export stills, working in After Effects primarily means you’ll be creating videos as 
your end product. If you’re new to working with video and/or to working with time, there are some 
important technical concepts you should know:

Common Frame Sizes
•	 Common video sizes: (Width/Height)
	 1920x1080: HD Video (16:9 aspect ratio)
	 1080x1920: Vertical/Social Media “Story” (9:16 aspect ratio)
	 1920x1920 or 1080x1080: Square (1:1 aspect ratio)
	 3840x2160: 4K Video (16:9 aspect ratio)
•	 After Effects can create and work with videos in nearly any size and aspect ratio, though many 

video file formats will have their own restrictions and limits. 
•	 When planning to post online, actual display resolutions can vary by site, and by the device they’re 

being viewed on, but it’s good to create at standard sizes like the ones listed below.
•	 Other elements like social media “stickers” or looping GIFs might be created at much smaller sizes.

Frame Rate / FPS
•	 A video file is made up of a series of still images, known as frames. A video’s frame rate is the 

number of frames in each second of that video. This is often listed as frames per second, or “FPS.”
•	 Common/standard frame rates: 
 	 30 FPS: American television standard
	 25 FPS: European television standard
	 24 FPS: Film standard

Timecode 
Timecode is a number that indicates where (when?) you currently are in the timeline. This is displayed 
in this format: 00:00:00;00 - hours : minutes : seconds : frames.
“0” is a frame, so in a 30 FPS composition, the first second would span from 00:00:00;00 - 00:00:00;29. 
Advancing one more frame would place you at 00:00:01;00.  

After Effects Composition Settings 
After Effects allows you to work at nearly any size and 
frame rate. Starting with the provided presets will help 
make sure you are aligned with technical standards for 
most uses.

When creating a composition, you’re provided with a pop-
up that includes many properties. 

Clicking on the Preset dropdown gives you a list of common 
specs to choose from, including many of the common 
formats listed above.

You can access these settings for existing compositions by 
choosing Composition > Composition Settings, or pressing 
CTRL/CMD+K.
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After Effects: Key Concepts
Workspaces
After Effects has various Workspaces, designed for different types of projects and workflows. 
You’ll find several in a bar along the top of the app, or under Window > Workspace. 

Default is a good place to start, and what I’m using for the entirety of this series.

If you’d like to learn more about After Effects, the Learn workspace will guide you through step-by-
step tutorials on a variety of techniques. Explore that after you finish up with my videos!

You can customize your workspace by dragging panels around, and placing them onto or alongside 
others. Want the original version of that workspace back? Choose Window > Workspace > Reset 
to Saved Layout. Save your own custom layouts by using Window > Workspace > Save As New 
Workspace.

Compositions
These are the “documents” you create in After Effects: you might think of it as a page in motion.
Compositions are represented by a little “multimedia” icon:  
Compositions can contain one layer or many layers of different types, and will always have a duration. 
You’ll navigate through time, adjusting layers and properties to create animation.

After Effects Project Files
An After Effects project uses the extension .aep. This project file can contain a single composition, 
or several. It will often contain references to several multimedia assets on your hard drive, plus 
elements created directly within After Effects itself. It’s usually best to save a series of animations for 
a single project within the same project file, and save unrelated animations in separate After Effects 
projects. Make sure to give your files a meaningful name, so you can find them later! 

Multimedia & Imported Assets
After Effects accepts many different kinds of multimedia files, including imported images, video, 
audio, and layers from properly-prepared Photoshop or Illustrator files. Files imported into After 
Effects are only references to these files on your hard drive; renaming, moving or deleting those 
files will cause them to become offline within After Effects, and they will be replaced with a color bar 
placeholder image. Elements created directly within After Effects (shape layers, text layers, etc.) live in 
the project file.

You should generally avoid using compressed media like .mp3 audio & .mp4 video, as they can slow 
down previews and may cause other unexpected behavior. Convert these files to uncompressed 
formats using Media Encoder before importing into After Effects. 

File Management
Because of the above, it’s a good idea to keep your files organized in your system’s file browser. I 
recommend having a specific, consistent location you keep project files and multimedia assets, and 
creating folders for each of your projects within that. Each of these project folders might then have 
sub-folders for assets like audio, graphics, video, scripts, and more, as appropriate for your project.
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Project Panel (More on page 8)
•	 Created Compositions and imported assets live here. 
•	 The top of the panel displays information about selected objects. 
•	 You can organize assets by creating folders.

Timeline (More on pages 10-15)
•	 Layers (vertical hierarchy of a layer stack, like Photoshop or Illustrator) + time.
•	 You can adjust and animate layers and/or properties here.
•	 Different layers can exist / be visible at different points in the timeline. 
•	 Each layer has a variety of switches, blending modes and other options available.
•	 Timecode (where you currently are in time) is displayed as hours : minutes : seconds : frames
•	 The blue “time cursor” is known as the CTI, or Current Time Indicator.

Composition Viewer (More on pages 16-17)
•	 This is where you see what you’re working on. 
•	 You can also visually select and transform layers in this panel. 
•	 Note: it’s possible to set this panel to different sizes and quality settings. If your art looks blurry or 

pixelated, confirm you’re set to 100% and Full before panicking.

Properties Panel (More on page 20)
•	 A contextual panel that shows you available properties of a selected layer. 
•	 Some layers will have more properties displayed than others.
•	 You can adjust and animate layers and/or most properties here. 

There are several other panels available in After Effects. We’ll be covering more as we get into our 
examples, and there are more we won’t be using for these lessons. Feel free to explore them yourself!

Project Panel

Timeline

Composition Viewer

Properties
Panel

After Effects UI at a Glance
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Most animation in After Effects is created using keyframes: these hold a specific value for a given 
property at a specific time on the timeline. 

To create a keyframe, click the stopwatch icon next to the property you want to animate, in either the 
Timeline or Properties Panel:  

Once activated, it will turn blue to indicate that this property is now being animated: 

When a property has at least two keyframes with different values, After Effects will move from the 
first value to the second, over the amount of time between the keyframes. This creates animation!
You can change the animation by changing the value of these keyframes, changing the time at which 
they occur, or by adding additional keyframes to this property.

You will see keyframes in the Timeline:

There are several different keyframe types, indicated by different shapes.  
Default (Linear) keyframes look like little diamonds, as seen in the timeline above.

Every layer (except audio-only layers) will have a set Transform properties you can edit or animate. 
This are shown in the Properties Panel when the layer is selected, or can be revealed in the Timeline 
by twirling open the desired layer.  

•	 Anchor Point: The point around which Position, Scale and Rotation happen. This defaults to the 
center of the layer, but can be changed. 

•	 Position: The location of this layer’s Anchor Point, relative to the composition. This property has 
two values: and X (horizontal) and Y (vertical).

•	 Scale: The size of this object, as a percentage of its original size. You can unlink this property to 
scale non-proportionally.

•	 Rotation: The angle of the layer, in both full rotations (first value) and degrees (second value).
•	 Opacity: 0-100% value indicating how transparent or opaque this layer is.

Animating a layer’s Position is probably the best place to start animating! 

Because After Effects is built for animation, nearly everything is totally non-destructive. Don’t be 
afraid to explore and play - it’s the best way to gain an understanding for how these properties work!

Keyframes

Transform Properties
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Project Panel: Overview
The Properties Panel is the “home base” for your project. 

At the top, you’ll see a thumbnail and technical info for the selected asset or composition.

The search bar allows you to search by name, file type, and more. This is useful for larger projects!

Imported assets and created compositions will all be shown here. They can be renamed, organized 
into folders and given label colors. (I highly recommend doing this for all projects!)

You can also view additional information about each asset, including file type, size, duration and file 
path (when applicable). 

You can hide columns or reveal additional ones by right-clicking any of the column titles.

Right-clicking in the empty area shows you a pop-up with options to create compositions, folders, and 
more, as well as options for importing files. 

Right-clicking individual files shows you a pop-up with additional technical options, the ability to 
replace this element with another file, reveal it within the project or in your file browser, and other 
useful tasks. 
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Importing Media
After Effects allows you to import a wide variety of media types. Most are imported directly from the 
Import dialogue, while a few have additional options.

To import a file, go to File > Import > File and then navigate to the 
desired file. You’ll find other options available here, including 
importing multiple files at once, specific filetypes, and projects 
from Adobe Premiere Pro.

You can also open the import browser by pressing CTRL/CMD+I, 
or by double-clicking in an empty area of the Project Panel.

Lastly, you can simply drag assets into the Project Panel, Timeline 
or Composition Viewer directly from your system’s file browser.

Importing Layered Photoshop & Illustrator Documents
Importing .psd or .ai files allows extra functionality: namely that 
you can access the layers inside!

In both cases, you’ll be given the option to import as Footage, 
which is effectively like importing a flattened image file, or as a 
Composition. Updates made inside these files will be seen by After 
Effects once saved in their respective apps.

While the Photoshop/Illustrator import options are named slightly 
differently, in both cases, the Composition option allows you to 
choose between Document Size and Layer Size.

•	 Document Size: All layers will have a bounding box with the dimensions of the entire document, and 
the Anchor Point will be at the center of that bounding box (not necessarily visually centered on 
the content).

•	 Layer Size: Each layer will have a bounding box per its own dimensions, and the Anchor Point will 
be centered according to the center of this specific element.  

•	 When importing Photoshop documents, you can also choose to make Photoshop Layer Styles 
editable in After Effects. 

Reminder: once a file is imported into After Effects, changing that file elsewhere will result in it being 
“Missing” in After Effects. This is indicated by a small color bars icon: 

You can reconnect missing media by right-clicking the asset and choosing Replace Footage > File.
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Timeline Panel: Overview
In addition to the controls available on each layer, there are several for the panel itself. 

Navigate the Timeline frame by frame by pressing Page Up (backward) and Page Down (forward).  
Hold Shift while pressing these keys to jump 10 frames at a time. 

1 The Composition Name will appear in a tab above this panel. The small “x” allows you to close this 
composition. The three-bar menu next to the name provides additional options. Multiple compositions 
can be open at once, and will be displayed in a series of tabs, similar to a web browser.  

2 Timecode & frame count is displayed to indicate the location of your CTI. These can be toggled by 
CTRL/CMD-clicking on this field. 

3 The Search Bar allows you to search for specific layer or property names. This is extremely useful 
for finding properties without twirling layers open, and for revealing the same property on multiple 
layers. You can also activate this by pressing CTRL/CMD+F when this panel is active. 

4 Mini-Flowchart shows you this composition in the broader context of the project. This can also be 
activated by pressing Tab.

5 These switches enable Shy, Frame Blending and Motion Blur on a composition level. See Layer 
Switches for more info. 

6 Open or close the Graph Editor to fine-tune the easing on keyframes.

7 These numbers indicate where (when) your CTI is currently located, as well as the overall duration 
of this composition. These numbers will vary depending on the current zoom level of your timeline.

8 The Work Area determines the portion of the timeline to be shown during preview and export. It’s 
common to change this frequently while working, which you can do by dragging either end (or the 
entire bar, once trimmed), or by pressing B to set the Beginning, and N to set the eNd.

9 See the approximate render time of the current frame.

10 Toggle the Switches and Modes columns (explained on the next page).

11 Drag this slider to zoom in/out to change the amount of time currently displayed in the timeline. You 
can also do this by pressing the + and - keys along the top of your keyboard.

1
3

4 5 6
7

88

9 10 11

2
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Timeline Panel: Layer Properties
Whether you’re working with imported elements or something created within After Effects directly, 
most layers will have the following standard controls available:

        1             2   3                     4                                   5                                            6                                                7

1 A/V Features allow you to toggle a layer’s visibility or audio on/off, or to solo or lock the layer.

2 Label has a default color, depending on layer type. This can be customized by clicking on the color 
chip. This same color will be reflected in the layer itself, in the main timeline area.
The label pop-up menu also allows you to select all layers of a particular color, so it can be a big 
workflow boost when used wisely!

3 # serves to keep track of your layers in the timeline. The top layer in the composition will always 
be #1, and each subsequent layer will be numbered accordingly. This is known as the layer’s index, 
and can also be used for more advanced purposes when incorporating a type of code known as 
expressions. 

4 Layer/Source Name can be toggled between Layer Name and Source Name, with the latter including 
the full file extension, and document name if applicable. The left side of the Layer Name has an icon 
indicating layer type. Layer Name can be customized by selecting the layer and pressing Enter. 

5 Switches control various properties and the overall appearance of the layer. These are explained in 
detail on the following page.

6 Modes is hidden behind Switches by default. The Toggle Switches/Modes button below this column 
will swap the two, or both can be revealed if desired. 
•	 Blending Modes can be used to composite layers based on a variety of properties, like luminance 

or color channels. See the user guide for a complete listing of this functionality.
•	 Preserve Transparency causes this layer to be restricted to the collective alpha channels of layers 

below it. (It’s only visible within whatever is visible on all the layers below.)
•	 Track Matte allows this layer to use another layer’s alpha or luminance (white/black) values to 

determine this layer’s visibility. This can also be inverted.

7 Parent & Link allows you to set this layer to follow another layer, known as Parenting. This can be 
set using either the dropdown menu or pickwhip (click and drag to desired Parent layer). Transform 
values will change to be relative to those of its Parent layer. You’ll see a similar pickwhip for individual 
properties, which can be linked to other properties of the same type.

The order of these columns can be changed by dragging the column title right or left.  
You can hide columns or reveal additional ones by right-clicking any of the column titles.
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Timeline Panel: Layer Switches

Three of these layer switches rely on the state of a similar-looking switch that applies to the entire 
composition (located just above and to the right of the layers), and some switches are only available on 
certain layer types.

From left to right:  

•	 Shy allows you to hide certain layers in the Timeline, once the composition-level Shy switch is 
enabled. I advise most beginners to avoid this switch, but it’s helpful to know it exists. If you’re ever 
exploring in a template or someone else’s project, and can’t figure out WHY you can’t find a layer ... 
it’s probably shied!  

•	 Continuous Rasterization / Collapse Transformations has two different functions, depending on 
the layer type. For imported vector artwork (Adobe Illustrator), enabling this switch means you 
can scale this layer without quality loss. When enabled on a Pre-Composition, this allows internal 
effects and blending modes to “pass through” to this composition.  

•	 Quality and Sampling toggles layer quality. (It’s usually best to just leave this one alone!) 

•	 Effect toggles all effects on this layer on/off.  

•	 Frame Blending is only available on video footage, and selects a method for handling frame 
interpretation when a layer has been re-timed.  

•	 Motion Blur enables Motion Blur for this layer, but will only display it when the Composition-level 
Motion Blur switch is also enabled. Additional Motion Blur options are available in Composition 
Settings, under Advanced.  

•	 Adjustment Layer is enabled by default when you create an Adjustment Layer, but can also be 
used to turn any existing layer into an Adjustment Layer.  

•	 3D enables 3D for this layer. Depending on the other layers present, this icon can change  
per layer to indicate “binning” - essentially a form of grouping for the way After Effects’ 3D space 
renders - and also to indicate text layers with per-character 3D enabled. 



Introduction to After Effects 12

Timeline Panel: Working with Layers
You can move layers forward/backward in time, trim them, determine their order in the vertical layer 
stack, and more. 

Moving layers Left/Right: 
Drag layers using your mouse, or use the bracket keys [ ] to move a layer’s in/out point to the current 
frame. Both of these functions can be done to multiple layers at once.

Note: it’s possible to drag a layer beyond the In/Out point of the actual timeline, which may make it 
inaccessible! The bracket keys are a good way to bring it back onscreen. 

Trimming layers:
Layers can also be trimmed (without moving) by dragging from the layer ends. You’ll see your cursor 
change to a double-headed arrow: . 
•	 You can also trim layers by pressing Alt/Opt with the bracket keys [ ].

Layer Duration:
Audio or video files have a set duration, as do created compositions. This is indicated by small 
triangles on the ends of the layer. 
You will not be able to drag the ends of such a layer beyond this duration.*
When trimming such a layer, you’ll see a “ghosted” segment, indicating the content that exists for this 
layer:  .

Still images, shape layers, text layers, etc. do not have a duration, and can be “trimmed” to any length. 
If you move one of these layers and then trim the In point to before it’s original start point, you will see 
this diagonal bar pattern. This doesn’t affect anything - it’s just for your reference!  

Moving Layers Vertically:
A layer’s position in the layer stack will determine its visibility in the viewer (assuming other layers 
overlap this one visually). You can simply drag layers up/down in the stack as desired.
•	 You can select the next layer above/below by pressing CTRL/CMD + Up/Down Arrow keys.
•	 You can move the currently selected layer up/down the layer stack by pressing CTRL/CMD + Alt/

Opt + the Up/Down Arrow keys. 

* You can get around this restriction by enabling Time Remapping, which is not explained in this guide.
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Timeline Panel: Editing Properties
Much of your actual animation work will be done directly in the Timeline, as not all properties are 
available in the Properties Panel. Click the layer twirly  to reveal properties, effects or keyframes. 
These same twirlies are available for each group, effect, etc. within the layer to further reveal/hide 
properties. 

You’ll find a large variety of properties available, with many being unique to specific layer types. 

Numerical Properties:
Most properties are represented by numbers, though some have 2 or 3 values grouped together.

You can edit property values by clicking and dragging on the value (left = lower value, right = higher 
value). Holding CTRL/CMD allows more precise control, while holding Shift allows you to move by 
larger increments. 

You can also click directly on a value and type in a new number. 

After Effects will also do simple math for you! Let’s say you want to move a layer exactly 100 pixels to 
the right of its current position. In this case, you’d click on the X value of this layer’s Position property, 
deselect that existing value using either your mouse or arrow keys, and then type “+100”. 
You can do addition(+), subtraction(-), multiplication (*) and division ( / ) in these fields. 

A red value indicates that this property is controlled by a small piece of code called an expression. 
These may not be directly editable without disabling the expression itself. 

Other Property Types:
Non-numerical properties like color pickers and many Shape Layer properties, may open a special 
pop-up to edit that property, or act as a toggle directly in the timeline. A few special property types 
(which will only exist in certain effects) can only be adjusted in the Effect Controls panel. 
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Timeline Panel: Working with Keyframes
In addition to adjusting values and moving layers, you can also move keyframes themselves.

The open layer below has keyframes on the Position property, as well as one of the properties within 
Drop Shadow, an effect that has been added to this layer.  

Create keyframes by clicking the stopwatch  for the desired property. 
Once a property is animated, you can add keyframes to a frame that doesn’t already have one by 
adjusting the property value, by clicking the central diamond in this icon , or by copy/pasting 
values (explained below). 

Navigate existing keyframes by dragging your CTI in the timeline (holding Shift will snap to existing 
keyframes), using the left/right arrows in this icon  or by pressing the J or K keys. 
Holding Shift while pressing J / K will jump only to keyframes on the selected layer or property. 

To move existing keyframes, simply click and drag with your mouse. Select multiple exposed 
keyframes (on a single layer or multiple layers) by dragging a marquee selection around them, or by 
Shift-clicking each desired keyframe.

Move keyframes a single frame left/right by holding Alt/Opt and pressing the Left/Right Arrow keys. 
Hold Shift as well to move 10 frames at a time. 

Copy/Pasting:
Keyframes can be copy/pasted, either to the same property (at a different time), or to similar 
properties on other layers. (You cannot paste Rotation data to Position, for example, though you could 
paste Rotation to another rotation-based property, like the Drop Shadow Direction property above. 
This copy/pasting can be done on multiple layers at once.

Creating pleasing motion is all about experimentation, review and iteration. Expect to move your 
keyframes around a lot! Notice in my video examples, I sometimes create keyframes at the frames 
I want them, but also occasionally create them at a semi-random frame, then move them to their 
desired frame. You’ll likely do plenty of both! 
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Composition Viewer: Overview
This is where you’ll look at your creations & watch previews.  The viewable area will vary depending on 
the dimensions of your current composition. (You can change these under the Composition Settings.) 

1 The composition’s name is visible here. The three-bar menu has several additional options.

2 / 3 You’ll adjust these zoom and quality settings frequently while working. Remember that these are 
for your preview & working purposes, and do not reflect what your final output will look like unless 
you’re at 100% and Full. You can also zoom using the mouse scroll wheel, or CTRL/CMD + or -.

4 Toggle the transparency grid / composition background color, when applicable.

5 View isolated color channels (Red, Green, Blue, Alpha).

6 Take a snapshot of your composition. Once a snapshot exists, the eyeball icon next to this will be 
available: clicking on it lets you temporarily view that snapshot for reference.

7 View the current timecode or frame number. This matches what’s shown in the Timeline.

8 When a 3D layer exists in your composition,  
this corner will display additional 3D options: 

Tip: Holding the Space Bar gives you a temporary Hand Tool, which you can use to move around in the 
viewer. This is very handy when zoomed in! 

1

2 3 4 5 6 7 8
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Composition Viewer: Working with Layers
You can also select and transform layers directly in this panel.

A layer’s bounding box shows you the space it occupies in the frame, and will match the layer’s label 
color. Simply click on a layer in the viewer to select it. You can multi-select layers by also holding Shift.
Once selected, you can transform the layer by moving or manipulating this bounding box.

Right-clicking a layer opens a large pop-up of layer actions and options. These are also available under 
the Layer menu up top, or by right-clicking the layer in the Timeline. 

You can nudge the Position of a selected layer a small amount by pressing the Arrow keys, and by a 
larger amount by also holding Shift. 

Layer & Footage Viewers
It’s also possible to open Layer and Footage viewers (they’ll open in the same area, as tabs) by double-
clicking on assets in the Timeline and Project Panel, respectively. This is effectively an “isolation mode” 
for these elements, when needed. If you ever find that the viewer doesn’t seem like it’s responding to 
your updates the way it should, double-check you’re looking at the correct one!
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Rulers, Grids & Guides
You can create and view a variety of guides 
for properly aligning your work. Most of 
these can be accessed in the View menu, 
and will be seen in the Composition Viewer.

Press CTRL/CMD+R to hide or reveal 
Rulers. When rulers are visible, you can 
drag guides from them and place them 
anywhere in the composition area. To 
remove a guide, drag it back into a ruler.

To precisely place a guide, right-click it, 
then enter the desired pixel value in the 
pop-up that appears.

After Effects also allows you to view a Grid and a Proportional Grid, both of which can be customized 
under Preferences > Grids & Guides. 

In the View menu, you can also enable snapping for Guides and the Grid (but not the Proportional 
Grid).

Many of these options can also be toggled via a small icon at the bottom of the 
Composition Viewer. 

This menu also allows you to easily toggle Title/Action Safe overlays, a common 
content requirement for video export, especially when working for broadcast. 
This overlay can also be easily toggled by pressing the apostrophe key ( ‘ ).

When importing a Photoshop document as a composition (not as footage), guides will be created in 
this newly-created composition.

Grid layouts can also be imported & exported via the View menu, enabling guide layouts to be shared 
between other Adobe apps.

Additionally, you can set any layer as a Guide Layer, which will be visible to you while working and 
during previews, but will not be visible in any exports. You can enable this from the Layer menu and 
enabling Guide Layer. This is also available by right-clicking on the layer. Guide layers have a small blue 
hashtag icon next to the layer name: 
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Composition Settings
There are several ways to open Composition Settings: 
•	 Composition > Composition Settings
•	 Right-click in the Composition Viewer or an empty area in the Timeline Panel and select 

Composition Settings from this pop-up.
•	 Press CTRL/CMD + K

Adjust the size and frame rate of the current composition, or choose from existing presets. You can 
also create and edit your own presets.

Pixel Aspect Ratio should typically be left at Square, unless you’re working with specific formats.

Resolution is simply another place to access to same setting found in the Viewer. 

Start Timecode can be adjusted if needed (I’d advise against it until you have more experience!)

Duration is one of the properties you’ll adjust a lot. You can alter this at any point, but it’s best to do it 
when beginning work in this particular composition. Note that reducing this later in a project could 
“strand” layers beyond the In/Out of the timeline. 

Background Color is only for your reference, and you’re free to change this to whatever makes it 
easier for you to work. This is adjusted per composition, but new compositions will re-use the most 
recently-chosen color. 

Find info about Advanced and 3D Renderer settings in the User Guide.

https://helpx.adobe.com/after-effects/using/composition-basics.html
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Properties Panel: Overview
This contextual panel displays properties for the selected layer(s). All layers with a visual component 
(anything besides audio-only layers) will have Layer Transform properties here. Additional properties 
will vary by layer type. 

Like working in the Timeline, edit values by click-dragging left or right, or by clicking on them and 
manually entering a new value. These fields also allow mathematical functions (+-/*).

Animate properties by clicking the stopwatch icon. Once animation is enabled for a given property, its 
stopwatch will change to  allowing you to navigate existing keyframes. 

						                               Shape Layer:                                  Text Layer:To the right are two examples of layers with 
a lot of content in the Properties Panel.

All properties available in the Properties 
Panel can also be adjusted and animated in 
the Timeline, by twirling open the desired 
layer. These are the same properties; this is 
simply a more-accessible place to find them 
without over-crowding your Timeline panel. 

This panel will frequently change height, 
depending on your selection and the 
options available. 

						              
Essential Properties are a more advanced 
(and really useful!) feature that allows you 
to promote & edit specific properties from 
within pre-compositions. 

These will also be visible and editable in this 
panel when enabled. See more information 
on this feature in the User Guide.

   

https://helpx.adobe.com/after-effects/using/essential-properties.html
https://helpx.adobe.com/after-effects/using/essential-properties.html
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Effects & Presets
There are a HUGE number of effects available in After Effects - it’s half 
the name, after all! It will be hard to do them much justice in this short 
guide, but I’ll cover some basics:

Effects can be found in the Effects & Presets panel. Effects are sorted 
into a variety of categories. Searching in this panel will reveal any effect 
or preset that contains the entered terms, so this is a great way to find 
specific effects, once you know what you’re looking for. 

To apply a desired effect, you can drag the effect from this panel onto 
the layer itself, in either the Timeline or Composition Viewer. If your 
layer is already selected, you can simply double-click the effect name in 
the Effects & Presets panel.

With a layer selected, you can also find all available effects under 
the Effect menu, or by right-clicking a layer and choosing Effect 
from the corresponding pop-up. Using these latter two options 
requires navigating the various effect categories, which can be a bit 
overwhelming for a newer user - it’s a lot to remember!

Once an effect has been applied to a layer, controls will show up in 
the Timeline (you may have to twirl the layer open to see these), and 
also in the Effect Controls panel, which typically shares space with 
the Project Panel. 

Available controls will vary widely, depending on the applied effect. 
These values can be modified from this panel, and clicking the 
stopwatch icon will enable animation for the property. 

Effects can be renamed by pressing Enter. Individual properties 
cannot be renamed.

You can copy/paste single effects or multiple effects between layers, and can copy/paste specific effect 
properties to similar values on other instances of the same effect, or similar values in other effects.

To get a better understanding of what each effect does and see suggestions on how/when to use them, 
I highly recommend this video series by Jake Bartlett, where he covers EVERY SINGLE EFFECT available 
in After Effects. 

Animation Presets can consist of many combination of settings, keyframes, and effects, and are also 
sorted into categories. Some, like text presets, can only be applied to the appropriate layer type.
The most important thing to note about presets is that any keyframes are applied at the time your CTI 
is current set to - so make sure you are positioned *when* you want to be, or get ready to move some 
keyframes!

You’ll find additional options under the Animation menu, allowing you to load external presets into After 
Effects, and to save your own presets for later use.

https://www.youtube.com/playlist?list=PLjNI3J96cKVKmujglFYJEkHzZwpwJ45LV


Introduction to After Effects 21

Special Layer Types
Imported media like images and video have standard controls available - typically just Transforms. 
After Effects allows you to create several special layer types, which can be found under Layer > New. 
While not all of these will be visible in your Composition Viewer, they will all appear as layers in the 
Timeline, and will have properties (often unique ones) that can be edited and animated. 

•	 Text is an editable text layer, with controls similar to other Adobe design apps. Text layers can also 
be animated on a per character/word/line basis, by creating Text Animators. You can convert an 
imported Photoshop text layer into After Effects Text at Layer > Create > Convert to Editable Text.

•	 Solid is typically just a composition-sized solid color. Size and color can be changed in the pop-up 
that appears on creation, or edited later by choosing Layer > Solid Settings. 

•	 Light creates a virtual light, which only affects 3D layers. You’ll have a variety of options in the pop-
up that appears on creation, or can be edited later by twirling open the layer in the Timeline, or 
by choosing Layer > Light Settings. Lights allow you to create realistic lighting and shadows when 
working with 3d layers or imported 3d objects. Lights cannot accept effects, masks or mattes.

•	 Camera creates a virtual camera, which only effects 3D layers. You’ll have a variety of options in the 
pop-up that appears on creation, or can be edited later by twirling open the layer in the Timeline, or 
by choosing Layer > Camera Settings. Cameras cannot accept effects, masks or mattes.

•	 A Null Object is a small, empty bounding box in the center of your composition. A null is used 
primarily as a useful way to move other layers via parenting, and will not show up in exports. 
Effects can be applied to Nulls, but since they are not visible, this is mostly used as a way to control 
the effects across multiple other layers via Property Links.

•	 A Shape Layer can be as simple or complex as you like - it’s essentially a miniature version of Adobe 
Illustrator, contained within a single layer. These can contain parametric shapes (created via 
specific values) or Paths created via the Pen tool. You can convert an imported Illustrator layer into 
a shape layer at Layer > Create > Convert Shapes from Vector Layer. A Shape Layer may contain 
a single shape or multiple shapes, and you can add or edit modifiers (similar to options available in 
Illustrator)that change the appearance of the layer contents in a variety of ways. 

•	 An Adjustment Layer is used primarily to apply effects to multiple layers at once. Any effects 
applied to an Adjustment Layer will be shown on all layers below it in the Timeline’s layer stack. 
Applying masks or track mattes can further affect the visibility of an Adjustment Layer, and thus 
the impact it has on the other layers in your composition. 

   
Solids, Nulls and Adjustment Layers will appear in your Project Panel, inside a folder named Solids.  
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Pre-Compositions
An existing composition can be dropped into any other composition (except itself). It is now referred to 
as a pre-composition, and allows you to treat it like a single layer anywhere it’s nested. You can double-
click this pre-composition to open and edit and contents. 

You can also create pre-compose 
any single layer or group of layers 
by selecting the desired layer(s) and 
choosing Layer > Pre-compose, or by 
pressing CTRL/CMD+Shift+C. You’ll then 
see this pop-up, where you can name 
the pre-composition and choose from a 
few other options. 

When pre-composing a single layer, you 
can choose to leave existing effects and 
Layer Transforms here, or push them 
into the pre-comp along with the layer.

Tip: Take the extra few seconds to give 
your compositions meaningful names! 
You’ll thank yourself later.

A composition can be nested within multiple other compositions, with all of them pointing back to the 
single source - this allows you to use it as a modular element, similar to working with Smart Objects, or 
with Symbols in Illustrator.
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Masks & Track Mattes
There are multiple methods to change which portions of an After Effects layer are visible. 
If you have a complex cut-out task, remember that it’s often easier to do that in Photoshop!

Masks: Masks can be drawn on a layer using the Shape Tool or Pen Tool  while the desired layer 
is selected. Masks will always move with the layer, but the Mask Path itself can be animated separately. 

A closed mask path will restrict the layer’s visibility to the mask contents. An open path will not affect 
the layer’s visibility, but can be used to drive effects or other properties. 

Masks will be shown in the Timeline within the layer contents. 
Here you can adjust or animate the Path, Feather, Opacity 
and Expansion, as well as invert the mask and set the mask 
mode. Masks are always set to Add by default.

Setting a mask’s mode to None will leave it visible in the viewer, but it will have no visible 
effect on the layer itself. 

A layer can have multiple masks, which can be combined, cut away, intersected and 
more by using the other modes. The end result will also depend on the order of the 
masks.

Track Mattes: Available in the Timeline, Track Mattes allow you to use alpha or luminance values from 
another layer to change the visibility of *this* layer. By default, the Track Mattes column shares space 
with Switches, and can be accessed by clicking Toggle Switches / Modes at the bottom of the Timeline 
panel. 

Unlike Masks, Track Mattes use two separate layers, and can be transformed or animated completely 
separately.

Use the pickwhip or Track Matte dropdown menu to select a layer 
to serve as this layer’s matte.

Once a matte has been chosen, its name will be displayed in the dropdown field. Using the switches 
to the right of this name, you can then toggle between an alpha matte (uses the other layer’s alpha 
channel, or overall visibility) or luma matte (which uses the other layer’s white/black values), as well as 
invert the matte.

A layer can only have one matte, but a given layer can serve as a matte for multiple other layers.

When set as a matte, a layer’s visibility switch will be disabled, but you can 
simply re-enable it if you’d like this layer to be visible. This enables you to 
create complex relationships, like using Blending Modes to composite a layer 
over or under its own matte. 

Effects: There are also a variety of effects that can change which portions of a layer are visible, by 
distorting the layer or changing its boundaries, modifying the layer’s own alpha values, or using similar 
information from other layers.
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Blending Modes
Available on most layer types, Blending Modes allow you to composite layers in a variety of ways, 
typically by affecting the layer’s luminance (white/black) or color information. These work just like the 
blending modes available in Photoshop and Illustrator.

The Modes column shares space with Switches, and can be 
accessed by clicking Toggle Switches / Modes at the bottom of the 
Timeline panel. You can also access these options under Layer > 
Blending Mode.

The list of Blending Modes is sorted by type:

Multiply makes white pixels transparent. It and similar modes will tend to darken 
your image.

Screen make black pixels transparent. It and similar modes will tend to lighten your 
image. 

Overlay & similar modes rely on whether underlying layers are lighter or darker 
than 50% gray.

Difference & similar modes are useful largely for utility purposes, like aligning a 
layer to a reference image. 

Hue, Saturation, Color and Luminosity composite this layer onto underlying content 
based on these properties.

Stencil and Silhouette modes create mattes based on this layer’s alpha or luminance 
information.

For a full listing of Blending Modes and how each is calculated, see the User Guide.

https://helpx.adobe.com/after-effects/using/blending-modes-layer-styles.html
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Previews

Exporting

Previewing is one of the most important things you’ll do in After Effects - 
you have to see what you’re creating, after all!

You’ll create most previews by simply pressing Space Bar, or by clicking 
the small “Play” button in the Preview Panel. 

Multiple other shortcuts are available and customizable in the Preview 
Panel, and each can actually be set differently, if desired. 

The Preview Panel gives you many options to control how your previews 
perform, whether they include audio and visible layer controls, what 
portion of the timeline they show you, where they start and end, and 
more. I highly recommend you familiarize yourself with these options, 
and customize them to meet the needs of your project. 

After Effects is a great place for creating content, but to show it to anyone else, you’ll need to export it.
The best way to do this is by choosing Composition > Add to Render Queue.

The Render Queue allows you to stack up multiple compositions to be rendered all at once, or you can 
just do one at a time. 

A queued composition gives you the ability to change the specific of the export format (Output Module) 
and export location & name (Output To). Each of these settings has a variety of presets available by 
clicking the  icon next to the blue text.

When you’re finished customizing the specifics of your export, simply click Render. You’ll see a blue 
progress bar & estimate for render time, then hear the most glorious little chime when it’s complete!

Previously-rendered compositions remain in the Render Queue (like item 1 above) unless you manually 
delete them. This can be a handy way to keep track of previous exports.

The world of export formats is a deep topic, but generally speaking: H264 is a good delivery format, 
especially for online content, while the High Quality preset is a good go-to for content going back into 
another multimedia app, like Premiere Pro. 
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Tips: Designing for Motion
You’ll often create designs in Photoshop or Illustrator, then import them into After Effects for 
animation. It’s important to prepare these designs correctly, to give yourself the necessary flexibility 
later. 

•	 After Effects (and video in general) uses the RGB color space. CMYK files often won’t import 
correctly, and if they do, they tend to cause trouble. If you’re ever having trouble with a specific 
file, this is a good first thing to check!

•	 If you’re adapting print designs for video/motion, it’s often beneficial to reduce the resolution  
and/or document size. Video is screen resolution - 72 ppi, and higher resolutions don’t bring any 
benefit in After Effects. Bringing very large documents into After Effects can be slower to process 
and preview, and may require scaling to extreme sizes to even fit into the frame.

•	 With the above in mind, you’ll also want to make sure you’re sizing assets to give yourself options 
in animation. If you import a 1920x1080 background texture into a composition of the same size, 
you don’t have too many options for animation anymore! 

•	 After Effects is a pixel-based program; scaling layers above 100% will result in pixelization & a loss 
of visual quality. For vector layers, you can use the Continuous Rasterization switch to enable 
Illustrator-style vector scaling. Shape Layers and text created in After Effects can also be scaled 
without quality loss.

•	 Generally, be thoughtful about how you plan to use different assets, and how they need to be 
structured to be most useful in your animation. 

Photoshop:
•	 After Effects can import layered PSD files.
•	 Ps groups become pre-compositions in AE.
•	 Photoshop text can be made editable in AE.
•	 Layer masks are not editable within AE.
•	 Smart Objects are treated like every other Ps 

layer & have no special functionality. 
•	 After Effects does not recognize artboards.

Illustrator:
•	 After Effects can import layered AI files.
•	 Each AI (top-level) layer will import as a 

separate After Effects layer. (Objects within 
layers are treated as one layer in AE.)

•	 Illustrator text cannot be made editable in AE, 
but can be copy/pasted. 

•	 After Effects does not recognize artboards.

These will each be 
imported as separate 
layers.

The objects within 
Bloom O1 will all be 
imported as a single 
layer named Bloom O1.

These will each be 
imported as separate 
layers.

These will each
be imported as
separate layers,
but placed within
a pre-composition
named Background. 
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Keyboard Shortcuts
After Effects has a *lot* of shortcuts & this list is far from comprehensive. 
Check out a full interactive (and customizable!) list under Edit > Keyboard Shortcuts.

Tools

	▶ V Selection Tool

	▶ H Hand Tool

	▶ Z Zoom tool (Click to zoom; click & drag to zoom to specific area. Hold Alt/Opt to zoom out.)

	▶ W Rotation Tool

	▶ A Anchor Point Tool

	▶ Q Select or cycle Shape Tool

	▶ G Pen Tool

Layer Transform Properties

	▶ A Anchor Point

	▶ P Position

	▶ S Scale

	▶ R Rotation

	▶ T Opacity

	▶ Hold Shift & press above keys to reveal additional properties

Timeline Navigation

	▶ Page Up Move forward one frame

	▶ Page Down Move backward one frame

	▶ Shift + Pg Up Move forward ten frames

	▶ Shift + Pg Down Move backward ten frames

	▶ Home/End Jump to beginning/end of timeline

	▶ +/-  Zoom in/out on timeline

	▶ J/K Jump to previous/next visible keyframe or marker

	▶ I/O Jump to in/out point of selected layer(s)

	▶ [ ] Move in/out point of selected layer(s) to current frame

	▶ Alt/Opt [ ] Trim in/out point of selected layer(s) to current frame

	▶ B/N Set Beginning or End of Work Area

Viewer Navigation

	▶ CNTL/CMD +/- or Mouse scroll wheel Zoom in/out

	▶ Hold Space Bar (Temporary) activate Hand tool to free-drag viewer
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Keyboard Shortcuts
Previewing

	▶ Space Bar Play/stop Preview

	▶ Numpad . Play audio-only Preview

Other Helpful Shortcuts

	▶ Enter Rename layer (or Effect, Shape Layer group, Text Animator, etc.)

	▶ Hold CTRL / CMD while adjusting values: precise movement

	▶ Hold Shift while adjusting values: change faster / by larger increment

	▶ Hold Shift while moving element: Snap (to X/Y axis, to other keyframes, etc.)

	▶ Hold Shift while drawing shape: Constrain to perfect square/circle

	▶ Tab Jump to next editable field

	▶ U Reveal keyframes on selected layer(s)

	▶ UU (Press twice quickly) Reveal all properties changed from default values

	▶ F9 Easy Ease selected keyframe(s)

	▶ CTRL/CMD+Z Undo 

	▶ CTRL/CMD+A Select All

	▶ CTRL/CMD+C Copy

	▶ CTRL/CMD+V Paste

	▶ CTRL/CMD+D Duplicate

	▶ CTRL/CMD+K Open Composition Settings

	▶ CTRL/CMD+S Save your beautiful work!


